« Can't load module XML::Parser::Expat, dynamic loading not available in this perl. (4/25) | トップページ | Perl 5.8.5 で crypt() 関数がエラー The crypt() function is unimplemented due to excessive paranoia. »

2006.04.25

Encode object version 2.01 does not match bootstrap parameter (4/25)

Linux Zaurus での Perl 5.8.5 の続き。今度は Encode.pm がエラーになってしまう件。

bash-2.05$ perl -wc test.cgi

Attempt to free unreferenced scalar: SV 0x2429cdc at test.cgi line 7.
Encode object version 2.01 does not match bootstrap parameter 2.15 at /usr/local/lib/perl5/5.8.5/armv5tel-linux/XSLoader.pm line 29.
Compilation failed in require at test.cgi line 7.
BEGIN failed--compilation aborted at test.cgi line 7.
bash-2.05$

本当の原因はわからないものの、とりあえず、Encode.pm のバージョンを 2.15 から 2.01 に下げて再インストールを行ったところエラーは出なくなりました。

とりあえず、これで Linux Zaurus 上の Perl で RSS, UTF-8 がいじれるようになったかな???

|

« Can't load module XML::Parser::Expat, dynamic loading not available in this perl. (4/25) | トップページ | Perl 5.8.5 で crypt() 関数がエラー The crypt() function is unimplemented due to excessive paranoia. »

コメント

コメントを書く



(ウェブ上には掲載しません)




トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/49099/9766049

この記事へのトラックバック一覧です: Encode object version 2.01 does not match bootstrap parameter (4/25):

« Can't load module XML::Parser::Expat, dynamic loading not available in this perl. (4/25) | トップページ | Perl 5.8.5 で crypt() 関数がエラー The crypt() function is unimplemented due to excessive paranoia. »